A critical vulnerability in PHP, the popular programming language powering over 70% of all websites, has forced an emergency security update. The flaw, discovered in October 2026, puts millions of sites at immediate risk of compromise.
What Is the 'PHP2Shell' Flaw?
Security researchers
have identified two critical vulnerabilities, collectively nicknamed 'PHP2Shell'. Tracked as CVE-2026-109618 and CVE-2026-109619, these flaws exist deep within the core PHP language itself, not in the applications built on top of it like WordPress or Drupal. Both vulnerabilities are severe, allowing for what is known as unauthenticated Remote Code Execution (RCE). In simple terms, this means a potential attacker could run their own malicious code on your web server without needing a username or password. This could give them the power to take over your site, steal sensitive data, or use your server for other malicious activities. The flaws are related to how PHP handles memory, particularly when it runs out or when information is incorrectly handled between user sessions.
The Widespread Impact
The reason this vulnerability has sent shockwaves through the web development community is PHP's immense popularity. It is the engine behind a vast majority of the internet, powering everything from small personal blogs to large corporate websites and e-commerce stores. Content Management Systems (CMS) like WordPress, Drupal, and Joomla, which together run on hundreds of millions of sites, are all built on PHP. While these platforms themselves are not flawed, their security relies on the underlying PHP installation being secure. This means that even if your WordPress or Magento installation is fully up to date with its own patches, your site remains vulnerable if the server it runs on is using an unpatched version of PHP. The issue affects nearly all versions of PHP, going back many years.
Are You At Risk and What Should You Do?
If your website runs on PHP, you should assume you are at risk until you can confirm otherwise. The official PHP development team released emergency patches on October 21, 2026. The patched versions are PHP 8.2.35, 8.3.36, 8.4.27, and 8.5.12. Any version prior to these should be considered vulnerable. Your immediate first step is to contact your web hosting provider or your development team. Ask them what version of PHP your server is running and when they will be applying the necessary security updates. If you manage your own server, you are responsible for updating the PHP package yourself and restarting the web server services to ensure the patch takes effect. Cybersecurity agencies like the US's CISA are strongly urging all organizations to patch immediately, and to even consider taking unpatched systems offline until they can be secured.
The Danger of Unsupported Versions
A significant concern is the large number of websites still running on older, end-of-life (EOL) versions of PHP, such as PHP 8.1 and earlier. The official PHP project no longer provides security updates for these unsupported versions. This means if your site is on one of these older versions, there is no official patch coming for you. This leaves you with two primary options: either upgrade your entire website environment to a supported PHP version (like 8.2 or newer) to receive the fixes, or rely on thirdrd party vendors who may offer extended support patches. Continuing to run an unsupported version of PHP is a major security risk, as known vulnerabilities like PHP2Shell are being actively scanned for and exploited by attackers.













