In late October 2026, security researchers announced a critical flaw in PHP, the programming language that powers an estimated 70% of the web. This is not just a problem for developers; it is an urgent issue for anyone who owns a website.
What Exactly Is the 'PHP2Shell' Flaw?
Collectively
nicknamed 'PHP2Shell', the issue actually consists of two separate but related vulnerabilities, identified as CVE-2026-109618 and CVE-2026-109619. Both are considered critical, with security experts rating them as high as 9.2 out of a possible 10 on the severity scale. In simple terms, these flaws exist deep within PHP's core code, specifically in how it handles memory when errors occur. This creates an opening that attackers can exploit to run their own malicious code on a web server without needing a password or any form of authentication. This is known as a Remote Code Execution (RCE) vulnerability, and it's one of the most dangerous types of security flaws.
Why This Affects Almost Everyone Online
PHP is one of the foundational technologies of the modern internet. It is the server-side language that runs a vast number of websites, from small personal blogs to large corporate platforms. Crucially, it's the engine behind the world’s most popular Content Management System (CMS), WordPress, which alone powers over 40% of all websites. It also runs other major platforms like Drupal, Joomla, and popular e-commerce software like Magento. Because the vulnerability lies in PHP itself, and not in a specific theme or plugin, the potential attack surface is enormous. Every website using an unpatched version of PHP is a potential target.
The Real-World Dangers for Your Website
If an attacker successfully exploits the PHP2Shell flaw on your server, the consequences could be severe. They could gain the ability to access and steal sensitive information, such as customer data from your database or private configuration files. They might deface your website, replacing your content with their own, or install malware that infects your visitors' computers. The compromised server could also be used as a launchpad for other illegal activities, like sending spam emails or participating in coordinated attacks on other networks, all while appearing to come from your business. Given that active exploitation attempts were detected within days of the flaw's disclosure, the threat is not theoretical.
How to Know If You Are Vulnerable
The vulnerabilities affect a wide range of PHP versions. The official patches were released for PHP versions 8.2, 8.3, 8.4, and 8.5. Versions 8.1 and older are no longer officially supported and did not receive direct updates, making sites that run them especially vulnerable. To check your site, you can typically find the PHP version listed in your hosting provider's control panel (often called cPanel or Plesk). If you use WordPress, you can find this information under 'Tools' > 'Site Health' > 'Info' > 'Server'. However, be aware that the version shown on the command line can sometimes differ from the one your web server uses, so checking through your web control panel is more reliable.
The Solution: Patch and Update Immediately
The PHP development team and global cybersecurity agencies like the UK's NCSC and the US's CISA have all issued urgent advisories: update immediately. A 'patch' in this case is a new, corrected version of the PHP software. You need to ensure your web server is running one of the fixed versions: 8.5.12, 8.4.27, 8.3.36, or 8.2.35. For most website owners, this action will be taken by their hosting provider. Many managed hosting companies have already applied these patches automatically. However, you should not assume you are protected. Contact your hosting provider or your web developer directly to confirm that your server's PHP has been patched against CVE-2026-109618 and CVE-2026-109619. If you are on an unsupported PHP version (8.1 or older), it is critical to plan an upgrade to a supported version as soon as possible.













