A pair of critical security flaws, disclosed in October 2026 in the PHP programming language that powers a vast number of websites, has sent developers and site owners scrambling to apply emergency patches.
What Is the PHP Flaw?
Dubbed 'PHP2Shell' by security researchers, the
issue consists of two distinct but related memory-safety vulnerabilities, identified as CVE-2026-109618 and CVE-2026-109619. Both are rated 'Critical' with a severity score of 9.2 out of 10. In simple terms, these flaws allow an unauthenticated attacker—someone with no login credentials—to send a specially crafted request to a server and potentially run their own code. This is known as Remote Code Execution (RCE) and is considered one of the most serious types of security threats. The vulnerabilities exist within the core PHP engine itself, meaning even a perfectly secure website application can be compromised if the underlying PHP software is vulnerable.
Who Is at Risk?
Any website running on a server with an unpatched version of PHP is potentially at risk. This includes millions of sites built on popular content management systems (CMS) like WordPress, Drupal, and Joomla, as all of them run on PHP. The vulnerabilities affect multiple PHP versions, with patches being released for the currently supported branches: 8.2, 8.3, 8.4 and 8.5. Importantly, websites running older, end-of-life versions of PHP, such as 8.1 or earlier, will not receive official fixes from the PHP project, making them permanently vulnerable unless they upgrade or use a third-party long-term support service. The highest-risk configuration is reported to be Apache servers using 'mod_php', where an exploit can be triggered with a single request before the website's own code even starts to run.
The Dangers of Inaction
The consequences of failing to patch this vulnerability are severe. A successful RCE attack grants the intruder the ability to take control of the website's server. They could steal sensitive data, such as customer information, passwords, and payment details from an e-commerce store. An attacker could also deface the website, install persistent backdoors to maintain access, or use the compromised server to launch further attacks on other targets. Given that details of the flaw leaked before the official patch was released, security firms reported seeing widespread scanning and exploitation attempts almost immediately, meaning the window to act is small.
How to Check and Patch Your Site
The first step is to identify which version of PHP your website is using. For WordPress users, this information is typically found in the 'Site Health' section of the admin dashboard under 'Tools'. The patched versions are 8.5.12, 8.4.27, 8.3.36, and 8.2.35. If your site is on a managed hosting plan, your provider is responsible for applying the server-level patch. Many major hosts acted within minutes or hours of the patch release. However, it is crucial to confirm with your provider that the update has been applied. If you manage your own server (such as a VPS or dedicated server), you must update the PHP packages yourself and, critically, restart the PHP service (e.g., PHP-FPM) to ensure the new code is loaded. CISA and other national cybersecurity agencies have strongly urged organizations to patch immediately or, if unable, take vulnerable systems offline.
Beyond the Immediate Fix
This incident serves as a critical reminder that website security is a multi layered responsibility. Simply keeping your CMS and plugins updated is not enough; the underlying server software must also be maintained. After patching, security experts recommend checking server logs and website files for any signs of compromise that may have occurred before the fix was applied, such as unfamiliar files or new admin accounts. For long term security, website owners should have a plan to stay on a supported PHP version, as running end of life software is a significant risk. This event highlights the importance of having an inventory of all places where PHP runs within an organization, from production servers to forgotten staging sites, to ensure every instance is secured.













